Errore Notice WP_Widget su WordPress 4.3.0

Con l’ultimo aggiornamento di WordPress alla versione 4.3.0 molti webmaster e possessori di siti web che utilizzano la nota piattaforma web WordPress avranno riscontrato un errore che dice:

Notice: Il metodo di costruzione richiamato per WP_Widget è deprecato dalla versione 4.3.0! Utilizzare invece __construct() in /directory/functions.php on line 3457

Oppure, la sua versione inglese:

Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use __construct() instead. in /directory/functions.php on line 3457

Vediamo nel dettaglio questo errore notice metodo di costruzione wp_widget deprecato

Nell’ultimo aggiornamento di WordPress sono state operate delle modifiche al cuore dello stesso, che hanno reso delle vecchie funzioni / metodi / strutture deprecate, ovvero da aggiornare. WordPress infatti, essendo sviluppato e mantenuto costantemente dai suoi sviluppatori, opera sempre delle modifiche che ne aumentino le potenzialità o ne aumentino le performance.

Quindi, è normale che alcune parti di software sviluppate da terzi ( come appunto temi, plugin, e modifiche di vario genere ) diventino col tempo datate e necessitino quindi di una riverifica e un refactoring.

Come risolvere l’errore metodo di costruzione Wp_Widget deprecato da 4.3.0

L’errore non è di facile soluzione. In realtà, molte aziende e molti webmaster stanno usando un metodo non corretto per correggere questo errore, ovvero stanno semplicemente silenziando il warning notice elevato da PHP, ma la soluzione non è questa, bensì quella di analizzare il plugin / tema che sta scatenando la notice, ed allinearlo alle più recenti guidelines sull’utilizzo della classe Wp_Widget

Questa operazione non è eseguibile da chi non possiede un elevato grado di familiarità e comprensione sia del codice PHP sia della piattaforma WordPress.

Per risolvere l’errore Wp_Widget deprecato ti consigliamo di contattare Web Sunrise

Affidati ai professionisti per risolvere questo problema, e non a fantomatici programmatori che non faranno altro che silenziare la notice elevata da PHP.

Sviluppo Web | | Commenti disabilitati su Errore Notice WP_Widget su WordPress 4.3.0

«

Web Sunrise sta caricando...